CCNA学习之路

admin 74 0

1. 网络基础

1.1 常见的网络接口

  • Ethernet(10M接口)
  • Fastethernet(100M接口)
  • Gigbitethernet(1000M接口)
  • Xgigabitethernet(光纤口)

1.2 网络的分类

  • 局域网 是交换机相连接的,相同IP地址段,进行数据转发。
    • 交换机是通过什么进行转发的? 通过MAC地址进行转发。会建立MAC地址表。
  • 城域网
  • 广域网 是路由器(路由设备)相连接的,不同IP地址段,进行数据转发。
    • 路由器是通过什么进行转发的?通过IP地址进行数据转发。会建立IP地址转发表,也叫路由表。

1.3 服务器的分类

服务器的分类,按形状分为塔式服务器、机架式服务器、刀片服务器以及高密度服务器。

CCNA学习之路

1.4 常见的网络端口

  • 80(http)
  • 443(https)
  • 20 和 21 (FTP)
  • 25(邮件服务器)
  • 23(telnet)
  • 22(ssh)
  • 53(DNS)
  • 3389 (RDP)
  • 3306(Mysql)
  • 1433(sqlServer或mssql)
  • 6379(redis)
  • 1521(oracle database)
  • 139或445(smb)

1.5 IP地址

1.5.1 IP地址的表现形式

IP作用于OSI参考模型中的网络层,在终端通信中作为唯一标识,便于确定数据的传递目标。

IP地址分为:IPv4 、IPv6IPv4就是IP的第4个版本,IPv6就是第6个版本。

大多数用户熟悉并且流行的IP地址是IPv4,其是用点分四组十进制的表示方法展示的,例如 119.91.77.247 、192.168.1.0等,每一组的数字都是非负的整数,范围在 [0, 255] 之间。

IPv4还有种写法是用二进制表示的,例如:

十进制的表现形式二进制的表现形式
192.168.1.100 11000000.10101000.00000001.1100100
119.91.77.2471110111.1011011.1001101.11110111
10.13.18.2100001010.00001101.000010010.10101
116.69.24.311110100.1000101.00011000.00011111

因此称IPv432位的。而IPv6的位数就比较大了,是128位的,长度是IPv44倍,并且其表示方式是分块的八组四个十六进制数,例如:5f05:2000:80ad:5800:0058:0800:2023:1d71,每个块儿之间都是用 : 隔开的。

IPv6看着特别得长,所以它得简化表示法已经有一套标准,规则如下:

  1. 每个块儿中前导的零可省略。例如5f05:2000:80ad:5800:0058:0800:2023:1d71 按照此规则简化后为 5f05:2000:80ad:5800:58:800:2023:1d71
  2. 整个块儿都为零的可以省略不写,并用 :: 代替其位置,但整个IPv6地址中只能出现一次 :: 符号。例如 0:0:0:0:0:0:0:1 按照此规则简化后为 ::1

当然IPv6也是可以用二进制表示的,表示结果如下:

十六进制的表现形式二进制的表现形式
5f05:2000:80ad:5800:0058:0800:2023:1d710101111100000101 0010000000000000 1000000010101101 0101100000000000 0000000001011000 0000100000000000 0010000000100011 0001110101110001
::10000000000000000 0000000000000000 0000000000000000 0000000000000000 0000000000000000 0000000000000000 0000000000000000 0000000000000001

如果把IPv6和端口号一起使用的话,可能会出现这样的情况:http://2001:0db8:85a3:08d3:1319:8a2e:0370:7344:443/,该URL中,最后一个 :443 其实表示的是端口号,但与IPv6一起使用时看起来好像也成为了一个块儿部分,因此我们需要用 [] 符号将IPv6部分包裹起来,结果如下:http://[2001:0db8:85a3:08d3:1319:8a2e:0370:7344]:443/

1.5.2 IP地址的结构

IP地址是作用终端设备的唯一地址,因此只有保证每个IP都不同时,才能保证其唯一特性。IPv4的长度为32,所以应该是2 ** 32,而IPv6的长度为2 ** 128种可能得地址。

这些地址就是作为数据包发送的目的地址,当然每个地址都会有它们各自的含义,例如单播 、组播 、广播等,当然还有一些地址是会被保留用于实验的。

  • 单播可以理解为一台主机发送单一的数据包给另一台主机;
  • 组播可以理解为一台主机发送单一的数据包给多台主机;
  • 广播可以理解为一个节点向其它所有的节点发送数据包;

IPv4种大多的数的地址都为单播

1.5.3 局域网IP地址

网络类别IP地址范围
A类10.0.0.0 ~ 10.255.255.255
B类172.16.0.0 ~ 172.31.255.255
C类192.168.0.0 ~ 192.168.255.255

1.5.4 分类寻址

分类寻址 (Classful Addressing):将 IP 地址分为 ABCDE 五类,三个主要类为 ABC 三类,区别在于网络号和主机号的长度,网络号和主机号的划分线在八位字节边界,如 C 类地址前 24 bits 为网络号,后 8 bits 为主机号。

CCNA学习之路

我们将IPv4地址的空间划分情况总结在了下表中:

地址范围网络数主机数
A类0.0.0.0 ~ 127.255.255.2552 ** 72 ** 24
B类128.0.0.0 ~ 191.255.255.2552 ** 14 2 ** 16
C类 192.0.0.0 ~ 223.255.255.2552 ** 21 2 ** 18
D类224.0.0.0 ~ 239.255.255.255//
E类240.0.0.0 ~ 255.255.255//

这里大部分的IP地址都是单播地址,但是每个网段的首尾也存在网络地址和广播地址。假设一个网段为192.168.1.0/24,那么192.168.1.0就是网络地址,而192.168.1.255就是广播地址。所以实际可以用到的ip地址为 2 ** 24 - 2

1.6 子网掩码

1.6.1 子网掩码的概述

子网掩码(subnet mask)又叫网络掩码、地址掩码、子网络遮罩,它是一种用来指明一个IP地址的哪些位标识的是主机所在的子网,以及哪些位标识的是主机的位掩码。

子网掩码不能单独存在,它必须结合IP地址一起使用。子网掩码只有一个作用,就是将某个IP地址划分成网络地址和主机地址两部分。 
子网掩码是一个32位地址,用于屏蔽IP地址的一部分以区别网络标识和主机标识,并说明该IP地址是在局域网上,还是在远程网上。

  • 通过子网掩码,就可以判断两个IP在不在一个局域网内部。
  • 子网掩码可以看出有多少位是网络号,有多少位是主机号。
CCNA学习之路

1.6.2 默认的子网掩码

A类地址的默认子网掩码255.0.0.0
B类地址的默认子网掩码255.255.0
C类地址的默认子网掩码255.255.255.0

但是这里有个问题,子网号和主机号都已经固定死了,而且每个子网所支持的主机数也是不一样的。比如一个部门只有10台电脑。那么我们使用默认的子网掩码255.255.255.0,IP地址为192.168.1.0 那么该网段可以容纳256个主机。其中减去网络地址和广播地址不能使用。可以使用的只有254台。那么岂不是有244个IP地址,还未使用。

为了减少浪费资源,因此有了子网划分的概念。专业名词叫做可变长子网长度(VLSM)。

1.6.3 可变长子网掩码

路由器在寻找子网号时,是通过我们设置的子网掩码来查找的,那么我们不妨根据不同的需求设置多个子网掩码,来达到子网号和主机号分配比例不唯一的需求,这就是VLSM(Variable Length Subnet Mask,可变长度的子网掩码)的实现。

比如某个部门被分配到了一个C类地址,如果使用默认的子网掩码,则可以容纳254个主机,但是实际上该部门只有10台PC,那么剩下的244个IP地址,都是闲置着的。

为了解决IP地址浪费的情况,就有了可变长子网掩码的诞生。

某公司现有一C类网段,192.168.1.0/24

目前有左侧4个部门:销售部 59台PC、技术部27台PC、业务部121台PC、会计部15台PC。

需求:将一个C类网段合理的分配给如下几个部门,保证地址不浪费:

按照先分多后分少的原则,因此先计算PC数量最多的业务部门。

业务部 121 台PC + 一个网关 + 一个不能使用的网络地址和一个广播地址 = 123 台

因此业务部门,至少要有123个地址。那么2的6次方是64,是不够的。2的7次方为128。所以2的7次方足够使用的。

IP地址:192.168.1.0 ---------- 192.168.1.127

子网掩码的计算:

128    64     32       16     8       4      2     1 

由于是2的7次方。所以从左往右减去7位。还剩下128。那么子网掩码就为255.255.255.128

CCNA学习之路

2. 协议基础

2.1 OSI七层模型

其实互联网的本质就是一系的网络协议,这个协议就叫OSI协议(一系列协议),按照功能不同,分工不同,人为的分为七层。实际上这个七层是不存在的。没有这七层的概念,只是人为的划分而已。区分出来的目的只是让你明白哪一层是干什么用的。

OSI七层模型全程为开放系统互连参考模型 (Open System Interconnect 简称OSI)是国际标准化组织(ISO)和国际电报电话咨询委员会(CCITT)联合制定的开放系统互连参考模型,为开放式互连信息系统提供了一种功能结构的框架。

CCNA学习之路

第一层为物理层,物理层为设备之间的数据通信提供传输媒体及互连设备, 为数据传输提供可靠的环境。比如说电脑的网线接口,就属于物理层

第二层为数据链路层,把实现控制数据传输协议的硬件和软件加到链路上就构成了数据链路上,该层发送是数据帧。该层的网络设备主要是交换机。比如说二层交换机。这里的二层指的就是数据链路层。二层交换机是通过MAC地址来进行寻址的

第三层为网络层,提供路由和寻址的功能,使两终端系统能够互连且决定最佳路径,并具有一定的拥塞控制和流量控制的能力。相当于发送邮件时需要地址一般重要。由于TCP/IP协议体系中的网络层功能由IP协议规定和实现,故又称IP层。三层交换机中的三层,指的就是网络层。交换机有了路由的功能,就是三层交换机。

该层的功能主要是用来寻址和路由。

第四层为传输层。传输层位于OSI参考模型的第四层,为相互通信的应用进程提供了逻辑通信,分段及封装应用层递来的数据。在传输层中常见的协议为TCP和UDP协议以及ICMP、RIP、EIGRP、OSPF等等。

第五层为会话层。会话层主要用于在不同机器上的用户之间建立会话,主要有安全协议:SSL安全套接字层协议,TLS传输层安全协议。目录访问协议:DAP目录访问协议,LDAP轻量级目录访问协议;远程过程调用协议RPCd;以上三个协议使用的还是比较少的,这些协议都是基于底层的TCP\UDP协议进行实现的。

第六层为表示层。表示层主要用于语法语义以及他们的关联,如加密解密,转换翻译、压缩解压缩
主要有LPP轻量级表示协议。

第七层为应用层。直接向用户提供服务,完成用户希望在网络上完成的各种工作。用层为用户提供的服务和协议有:文件服务、目录服务、文件传输服务(FTP)、远程登录服务(Telnet)、电子邮件服务(E-mail)、打印服务、安全服务、网络管理服务、数据库服务等。

2.2 ARP协议

地址解析协议(Address Resolution Protocol),其基本功能为透过目标设备的IP地址,查询目标设备的MAC地址,以保证通信的顺利进行。它是IPv4中网络层必不可少的协议,不过在IPv6中已不再适用,并被邻居发现协议(NDP)所替代。

2.2.1 ARP协议的工作流程

假设主机A和B在同一个网段,主机A要向主机B发送信息,具体的地址解析过程如下:

(1) 主机A首先查看自己的ARP表,确定其中是否包含有主机B对应的ARP表项。如果找到了对应的MAC地址,则主机A直接利用ARP表中的MAC地址,对IP数据包进行帧封装,并将数据包发送给主机B。

CCNA学习之路

(2) 如果主机A在ARP表中找不到对应的MAC地址,则将缓存该数据报文,然后以广播方式发送一个ARP请求报文。ARP请求报文中的发送端IP地址和发送端MAC地址为主机A的IP地址和MAC地址,目标IP地址和目标MAC地址为主机B的IP地址和全0的MAC地址。由于ARP请求报文以广播方式发送,该网段上的所有主机都可以接收到该请求,但只有被请求的主机(即主机B)会对该请求进行处理。

CCNA学习之路


3) 主机B比较自己的IP地址和ARP请求报文中的目标IP地址,当两者相同时进行如下处理:将ARP请求报文中的发送端(即主机A)的IP地址和MAC地址存入自己的ARP表中。之后以单播方式发送ARP响应报文给主机A,其中包含了自己的MAC地址。

CCNA学习之路

(4) 主机A收到ARP响应报文后,将主机B的MAC地址加入到自己的ARP表中以用于后续报文的转发,同时将IP数据包进行封装后发送出去。

2.2.2 ARP报文

CCNA学习之路

先要清楚,一般说以太网地址就是指MAC地址。

  字段1是ARP请求的目的以太网地址,全1时代表广播地址。

  字段2是发送ARP请求的以太网地址。

  字段3以太网帧类型表示的是后面的数据类型ARP请求和ARP应答这个值为0x0806

  字段4表示硬件地址类型,硬件地址不只以太网一种,是以太网类型时此值为1

  字段5表示要映射的协议地址的类型,要对IPv4地址进行映射,此值为0x0800

  字段6和7表示硬件地址长度和协议地址长度,MAC地址占6字节,IP地址占4字节

  字段8是操作类型字段,值为1,表示进行ARP请求;值为2,表示进行ARP应答;值为3,表示进行RARP请求;值为4,表示进行RARP应答

  字段9是发送端ARP请求或应答的硬件地址,这里是以太网地址,和字段2相同。

  字段10是发送ARP请求或应答的IP地址

  字段11和12是目的端的硬件地址和协议地址

2.2.2.3 抓包分析

主机A发送广播包到交换机的所有接口,主机B收到之后,会告诉主机A,主机B192.168.1.120的MAC地址是00:e0:4c:97:91:4b

CCNA学习之路
ARP请求报文分析
CCNA学习之路

这里的目的广播地址,为什么全为0呢?因为此时还不知道目的mac地址,因此使用0填充。

ARP响应报文分析
CCNA学习之路

2.2.4 arp地址表

设备通过ARP解析到目的MAC地址后,将会在自己的ARP表中增加IP地址到MAC地址的映射表项,以用于后续到同一目的地报文的转发。

CCNA学习之路
动态ARP表

动态ARP表项由ARP协议通过ARP报文自动生成和维护,可以被老化,可以被新的ARP报文更新,可以被静态ARP表项覆盖。当到达老化时间、接口down时会删除相应的动态ARP表项。

静态ARP表

静态ARP表项通过手工配置和维护,不会被老化,不会被动态ARP表项覆盖。
配置静态ARP表项可以增加通信的安全性。静态ARP表项可以限制和指定IP地址的设备通信时只使用指定的MAC地址,此时攻击报文无法修改此表项的IP地址和MAC地址的映射关系,从而保护了本设备和指定设备间的正常通信。

CCNA学习之路
CCNA学习之路

2.2.5 ARP欺骗攻击

在局域网中,黑客经过收到ARP Request广播包,能够偷听到其它节点的 (IP, MAC) 地址, 黑客就伪装为A,告诉B (受害者) 一个假地址,使得B在发送给A 的数据包都被黑客截取,而B 浑然不知。

3. RARP协议

RARP:Reverse Address Resolution Protocal,反向地址解析协议。允许局域网的物理机器从网关服务器的ARP表或缓存上请求IP地址。

比如局域网中有一台主机只知道自己的物理地址而不知道自己的IP地址,那么可以通RARA协议发出征求自身IP地址的广播请求,然后由RARP服务器负责回答。

它的功能就是根据MAC获取IP地址,功能跟DHCP是一样的。

3.1 RARP的工作流程

1 、一个电脑刚接入网络,没有IP地址就无法上网,此时它便会通过本地MAC地址,对外发送一个本地RARP广播,在广播包中,声明自己的MAC地址并且请求任何收到此请求的RARP服务器分配一个IP地址。

CCNA学习之路

2、本地网段的RARP服务器收到此请求后,检查其RARP列表,查找该MAC地址对应的IP地址。

CCNA学习之路

3 、如果存在,RARP服务器就给源主机发送一个响应数据包,并将IP地址提供给对方主机使用。

CCNA学习之路

4 、如果不存在,RARP服务器对此不做任何响应。

CCNA学习之路

5 、源主机收到从RARP服务的响应信息,就利用得到的IP地址进行通信。如果一直没收到RARA服务器的响应信息,表示初始化失败。

3.2 RARP的一些问题

1、RARP Server必须提前将MACIP的映射静态绑定在本地;若没有提前绑定,则电脑用自己MAC询问时,Server也不会回应;

2、RARP Server只能给电脑分配IP地址,不包括其他信息,包括网关、DNS等信息;

3、RARP基于二层封装,只能运行在同一网段;每个网段分配地址,都需要一个RARP Server

3.3 RARP协议的抓包分析

为了能够抓取到rarp的请求和回复包,首先打开wireshark抓取电脑网卡流量并设置arp过滤,然后采用两条命令:第一条命令模拟我的电脑发起的RARP请求包,第二条命令模拟局域网网关设备(极路由)返回的RARP回复包。

# 第一条命令
sudo  nping --arp-type RARP  --arp-sender-mac ac:bc:32:8b:56:df --arp-sender-ip 0.0.0.0 --arp-target-mac ac:bc:32:8b:56:df --arp-target-ip 0.0.0.0 192.168.199.255

# 第二条命令
sudo nping --arp-type RARP-reply  --arp-sender-mac d4:ee:07:54:c1:9e --arp-sender-ip 192.168.199.1 --arp-target-mac ac:bc:32:8b:56:df --arp-target-ip 192.168.199.153 192.168.199.153
RARP请求包分析
CCNA学习之路
RARP响应包分析
CCNA学习之路

3. 网络设备的介绍

3.1 网络设备操作系统

互联网操作系统(Internetwork Operating System,简称IOS)是思科公司为其网络设备开发的操作维护系统。

3.2 网络设备的存储器

3.2.1 ROM

ROM (Read Only Memory)中存储路由器加电自检(POST:Power-On Self-Test)、启动程序(Bootstarp Program)和部分或全部的IOS,路由器中的ROM是可擦写的。所以IOS是可以升级的。

ROM是存放引导系统的。

3.2.2 NVRAM

NVRAM (Nonvolatile Random Access Memory)非易失性随机存取存储器,存储路由器的启动配置文件,NVRAM是可擦写的,可将路由器中的配置信息拷贝到NVRAM中。

3.3.3 FLASH RAM

闪存,是一种特殊的ROM,可擦写的,也可以编程。用于存储Cisco ios的其它版本。用于对路由器的ios进行升级。

3.3.4 RAM

RAM (Random Access Memory) 随机存储器,RAM与PC机上的随机存储器相似,提供临时信息的存储,同时保存着当前的路由表和配置信息。

3.3 Cisco设备的简单启动过程

  1. 硬件自检
  2. 定位并加载Cisco ios镜像文件
  3. 定位并运行配置文件

4. 路由基础

4.1 路由的概述

路由是一种从源主机到目标主机的转发过程,它的工作原理是根据路由表进行转发,该路由表可以是静态的也可以是动态的。

4.1.1 路由表的定义和作用

路由表的定义是路由器中维护的路由条目的集合,他的作用是根据路由表做路径选择。

4.1.2 选择最佳路由的标准

1.有效的下一跳IP地址:路由进程收到更新和其他信息后,路由器首先检查路由的下一跳IP地址是否有效

2.度量值:如果下一跳有效,路由协议将按度量值最小的原则来选择到给定目的地的最佳路径。然后,路由协议将选择的路径加入到路由表中

3.管理距离:接下来需要考虑的是管理距离。如果从不同路由获悉了多条前往同一个网络的路由(前缀相同),路由器将根据路由来源的管理距离来决定哪条路由加入到路由表中。管理距离最小的路由将加入到路由表中,而其他路由将找到拒绝。

直连接口-0,OSPF-110,IS-IS-115,RIP-120,ODR-160

4.前缀:路由器查看通告的前缀。在路由表中,可以有前往同一个网络但前缀不同的路由。如果路由表中有多条前往同一个目的地的路由,将使用前缀最长的那条。

4.1.3 路由表的形成

  • 直连路由―本地接口配置IP地址和子网掩码,端口开启后,形成的路由
  • 非直连路由―不是本地接口配置IP地址和子网掩码,接口开启后形成的路由

对于非直连路由的学习,有两种方式:
一种是管理员手动添加 → 静态路由
一种是路由器通过路由协议自动学习的方式 → 动态路由

4.2 静态路由

4.2.1 静态路由的特点

特点:管理员添加的路由的传输方向是单向的(一方固定为接收端,另一方固定为接收端,数据只能向一个方向传输,不能有反向链路或通道)

优点:配置灵活,管理员手工配置,节省链路开销

缺点:当拓扑较大时,需要管理员去每台路由器上修改路由配置,比较麻烦

静态路由协议只能用于小规模的企业网络,大型企业网络用的是动态路由协议

4.3 默认路由

默认路由时静态路由的一种特殊形式,它属于静态路由的一种。

表现形式: 0.0.0.0/0 (所有网段)

作用:当路由器在路由表中找不到目标网络的路由条目时,路由器把请求转发到默认路由接口

配置命令:

ip route 0.0.0.0 0.0.0.0 <next_ip>

4.4 动态路由

动态路由就是路由器根据协议查找网络并更新路由表。

4.4.1 动态路由的选择

动态路由选择就是路由器根据协议查找网络并更新路由选择表,使用动态路由选择要比使 用静态或默认路由选择容易,但会占用更多的路由器 CPU 处理时间和网络带宽。

选择最佳路由的规则,是由如下几点衡量的:

1. 管理距离

AD (AdminisativeDistance,管理距离)用来衡量路由器已接收到的、来自相邻路由器的路由选择信息的可信度。管理距离可以是一个 0-255 之间的整数,其中 0表示最可信赖, 255则意味着不会有通信量通过这个路由。

CCNA学习之路

管理距离是可以别修改的。

2.路由选择协议

  • 距离矢量,距离矢量协议通过判断距离确定当前到达远程网络的最佳路径,例如RIP路由选择的应用中,分组每通过一个路由器,就称为一跳。到达目标网络需要最少条数的路由被认为最佳路由RIPIGRP都属于距离矢量路由选择协议。他们定期发送整个路由选择表给直接相连的路由器。
  • 链路状态,链路状态协议,又称最短路径优先协议,路由器将分别创建3个彼此独立的表,其中的一个表用来跟踪直接相连接的邻居,一个用来确定整个互联网的拓扑结构,而一个表则用作路由选择表。链路状态路由器要比任一使用距离矢量路由选择协议的路由器了解更多地关于互联网络的情况。
  • 混合型,混合型协议,将同时具有距离矢量链路状态的两种协议的特性,例如EIGRP,没有哪一种路由选择协议配置方式适用于所有情况,具体情况应具体分析。只有了解不同路由选择协议的工作方式,我们才能做出好的,正确的选择,从而真正满足具体的应用需要。
CCNA学习之路

4.4.2 路由环路

路由环路(Routing Loop)是一种在路由部署不恰当或网络规划不合理等情况发生后,很容易引发的一类问题,如果网络中的路由信息不正确,将导致去往某个目的地的数据包在设备之间不停地被来回转发,从而严重影响设备性能,并且大量消耗,网络带宽,影响正常的业务流量,这种问题被称为路由环路问题。路由环路对于网络而言是具有严重危害的,几乎所有的动态路由协议在协议设计时便考虑了路由环路的规避机制。

CCNA学习之路

R1路由要去往百度Server,按照路径最优的方法, 下一跳次数越少的越优,如果R1通过R2再到R3,之后再到百度的话,需要三跳,而R1通过R3直接去往百度的话,需要两跳,因此会走R3,但是到了R3之后,R3并不会直接到百度,而是走了R2,就这么一直循环就导致了环路。

造成环路最根本的原因就是路径不优的问题。

解决环路的方法:

CCNA学习之路

1.水平分割

从一个接口收到的路由,不会再从这个接口发送出去。

2.路由中毒(毒性逆转的水平分割)

从一个接口接收到的路由会从这个接口发送出去,但是将这条路由标记为16跳<不可达状态>

其实这是为了给RIPv2的确认作用(确认消息),因为在RIPv2的版本中是有触发更新的,一旦有触发更新就意味着说,我把我这条目,一旦有了新增的条目,对方必须给我一个确认消息,而这种确认就是由16跳进行体现的。

指发出一条路由,路由的METRIC为无穷大(16跳),作用是通知别的路由器,这条路由已经不可达了。

3.保持失效计时器

每一条路由表里面的路由,都有一个失效计时器,路由表都是每隔30秒进行周期更新,同时也会有180秒无效计时器,当180秒之后还没有收到再次发来的更新,路由器会认为该条目可能是down掉了,会将最开始接受到的路由条目标识为可能是down掉的状态,之后再等60(有的是240)秒,如果再没有收到更新,则会将该条目从路由表中删除。

4.触发更新

当路由表发生变化时路由器立即发送更新信息。

5.最大跳数

RIP所允许的最大跳计数为 15,所以任何需要经过16跳才能到达的网络都被认为是不可达的。换句话说,在循环到15跳后,路由器将被认为是已失去连接。因此,最大跳计数可控制路由选择表中的表项在达到多大的数值后变为无效的或不可信的。

在RIP协议中一般使用毒性逆转,在EIGRP协议中使用普通水平分割。这是默认的。

4.5 RIP协议

4.5.1 RIP协议的概述

RIP(RoutingInformationProtocol,路由信息协议)是一个纯粹的距离矢量路由选择协议。 RIP每隔 30秒就将自己完整的路由选择表从所有激活的接口上送出RIP只将跳计数作为判断到达远程网络最佳路径的依据,并且在默认情况下允许的最大跳计数为 15,也就是说16跳就被认为是不可达的

目前RIP协议分为RIPv1RIPv2两个版本,RIPv1是没有触发更新的但是他又周期更新(每30秒更新一次),而RIPv2,是有触发更新的同时它也有周期更新。

RIP版本1只使用有类的路由选择,即网络中的所有设备都必须使用相同的子网掩码。这是因为RIP版本1在其发送的更新数据中不携带子网掩码信息。RIP版本2提供了前缀路由选择信息,并可以在路由更新中传送子网掩码信息。这就是无类的路由选择。

​ RIP 基于UDP 520 端口工作 使用跳数来作为度量

4.5.2 RIP定时器

RIP使用了4种定时器来管理性能

  • 路由更新定时器(周期更新),用于设置路由更新的时间间隔(通常为30秒),此间隔是路由器发送自己路由表的完整副本给所有相邻路由的时间间隔。
  • 路由失效定时器,用于路由器在最终认定一个路由为无效路由之前需要等待的时间(通常为180秒),如果在这个认定的等待时间里,路由器没有得到任何关于特定路由的更新信息,路由器将认定这个路由无效。
  • 保持失效定时器,用于设置路由选择信息被抑制的时长,当路由器接收到某个表示路由器不可达(可能down掉了)的更新分组时,它将进入保持失效状态,这一保持状态将一直持续到路由器接收到具有更好度量的更新分组,或出事路由恢复正常,默认情况下,该定时器的取值为180秒。
  • 路由刷新定时器,用于设置将某个路由认定为无效路由起至将它从路由表中删除的时间(通常为240秒),在此将路由从路由表中删除之前,路由器会将此路由即将消亡的消息通告给相邻设备。路由失效定时器的值一定要小于路由刷新定时器,这就为路由器在更新本地路由表时先将这一无效路由通告给相邻设备保留了足够的时间。

定时器的总结:

每一条路由表里面的路由,都有一个失效计时器,路由表都是每隔30秒进行周期更新,同时也会有180秒无效计时器,当180秒之后还没有收到再次发来的更新,路由器会认为该条目可能是down掉了,会将最开始接受到的路由条目标识为可能是down掉的状态,之后再等60(有的是240)秒,如果再没有收到更新,则会将该条目从路由表中删除。

4.5.3 v1和v2的区别

  1. v1 为有类别路由协议----不携带子网掩码 按主类计算
    v2 为无类别路由协议—携带子网掩码
  2. v1 为广播更新 255.255.255.255
    v2为组播更新 224.0.0.9
  3. v2 支持手工认证

4.4 路由的基础配置

4.4.1 route的几种模式

Router> 用户模式

Router# 特权模式

Router(config)# 全局配置模式

Router(config-if)# 接口配置模式

R1(config-line)# console接口配置模式

4.4.2 基础配置

用户模式下常用命令:

enable                    # 进入到特权模式
telnet 192.168.1.1        # 连接telnet

特权模式下常用命令:

show version              # 查看版本及引导信息
show ip interface brief   # 查看接口列表
show running-config       # 查看设备正在运行的所有配置
show ip route             # 查看路由信息
show line                 # 查看登录的用户
show users all            # 查看用户远程登录的ip
show ip protocols         # 列出当前路由器所运行的协议
clear line 2              # 下线某个用户的登录,数值为tty ID
write                     # 将内存配置保存到硬盘
copy running-config startup-config   # 与write命令功能一致
config terminal           # 进入到全局配置
disable                   # 进入到用户模式

全局配置下常用命令

hostname R1    # 修改主机名为R1
no ip  domain lookup  # 关闭域名解析 
ip route <target_ip> <target_maks> <next_ip> 配置一个静态路由
no ip route <target_ip> <target_maks> <next_ip>  删除这个静态路由
enable password cisco  # 从用户模式到特权模式的密码为cisco,可以通过配置文件看到明文
enable secret cisco   # 从用户模式到特权模式的密码为cisco,可以通过配置文件看到其密文
line console 0    # 进入到console接口
line vty 0 2     # 进入到telnet配置接口,允许同时3个用户登录
interface ethernet 0/0  #  进入到某个接口
erase startup-config     # 清除所有配置
reload                  # 重启设备

接口配置模式常用命令

no shutdown     # 启动端口
shutdown        # 关闭端口
ip address 192.168.1.1 255.255.255.0   # 为该端口设置IP地址、子网掩码

console接口配置模式常用命令

no exec-timeout       # 关闭会话超时
exec-timeout 5        # 启动会话超时为5分钟
logging synchronous   # 开启同步记录功能

telnet接口配置常用命令

password x1ong        # 配置telnet的登录密码为x1ong
transport input telnet  # 允许远程连接telnet协议
login   # 允许登录

退出命令

exit            逐级回退
end             退到特权模式

4.3.3 静态路由的配置

网络拓扑如下:

CCNA学习之路

R2的配置:

Router>
Router>enable
Router#
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no ip domain lookup
Router(config)#hostname R2
R2(config)#line console 0
R2(config-line)#no exec-timeout
R2(config-line)#logging synchronous
R2(config-line)#exit
R2(config)#interface ethernet 0/0
R2(config-if)#ip address 192.168.1.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#interface ethernet 0/1
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#end
*Sep  4 01:31:39.566: %SYS-5-CONFIG_I: Configured from console by console
R2(config-if)#
R2(config-if)#
R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                192.168.1.1     YES manual up                    up
Ethernet0/1                192.168.2.1     YES manual up                    up
Ethernet0/2                unassigned      YES unset  administratively down down
Ethernet0/3                unassigned      YES unset  administratively down down
R2(config)#
R2(config)#ip route 192.168.4.0 255.255.255.0 192.168.2.100

R3的配置

Router>
Router>enable
Router#configure terminal
Router(config)#no ip domain lookup
Router(config)#line console 0
Router(config-line)#no exec-timeout
Router(config-line)#logging synchronous
Router(config-line)#exit
Router(config)#hostname R3
R3(config)#interface ethernet 0/0
R3(config-if)#ip address 192.168.2.100 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#interface ethernet 0/1
R3(config-if)#ip address 192.168.3.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#
R3(config-if)#
R3(config-if)#exit
R3(config)#ip route 192.168.4.0 255.255.255.0 192.168.3.100
R3(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1

R4的配置

Router>enable
Router#configure terminal
Router(config)#no ip domain lookup
Router(config)#hostname R4
R4(config)#line console 0
R4(config-line)#no exec-timeout
R4(config-line)#logging synchronous
R4(config-line)#exit
R4(config)#interface ethernet 0/0
R4(config-if)#ip address 192.168.3.100 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#interface ethernet 0/1
R4(config-if)#ip address 192.168.4.1 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#ip route 192.168.1.0 255.255.255.0 192.168.3.1
CCNA学习之路

最终192.168.1.100 可以ping通192.168.4.100主机。

4.3.4 RIP路由的配置

网络拓扑图如下:

CCNA学习之路

R1路由器的配置:

Router>enable
Router#configure terminal
Router(config)#interface loopback 0
Router(config-if)#ip address 1.1.1.1 255.255.255.0
Router(config-if)#
Router(config-if)#interface ethernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#
Router(config)#no ip domain lookup
Router(config)#line console 0
Router(config-line)#no exec-timeout
Router(config-line)#logging synchronous
Router(config-line)#exit
Router(config)#hostname R1
R1(config)#router rip
R1(config-router)#no auto-summary
R1(config-router)#version 2
R1(config-router)#network 1.1.1.0
R1(config-router)#network 192.168.1.0
R1(config-router)#end 
R1#write 

R2的配置

Router>
Router>enable
Router#configure terminal
Router(config)#no ip domain lookup
Router(config)#line console 0
Router(config-line)#no exec-timeout
Router(config-line)#logging synchronous
Router(config-line)#exit
Router(config)#hostname R2
R2(config)#interface ethernet 0/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#interface ethernet 0/1
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#no auto-summary
R2(config-router)#version 2
R2(config-router)#network 192.168.1.0
R2(config-router)#network 192.168.2.0
R2(config-router)#end 
R2#write 

R3的配置

Router>enable
Router#
Router#
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no ip domain lookup
Router(config)#line console 0
Router(config-line)#no exec-timeout
Router(config-line)#logging syn
Router(config-line)#logging synchronous
Router(config-line)#exit
Router(config)#hostname R3
R3(config)#interface ethernet 0/0
R3(config-if)#ip address 192.168.2.2 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#interface loopback 0
R3(config-if)#ip address 3.3.3.3 255.255.255.0
R3(config-if)#exit
R3(config)#router rip
R3(config-router)#no auto-summary
R3(config-router)#version 2
R3(config-router)#network 192.168.2.0
R3(config-router)#network 3.3.3.0
R3(config-router)#end 
R3#write 
CCNA学习之路

从途中可以看到,这里是可以跟3.3.3.3通信的,只查看rip协议的路由表发现已经增加了两条RIP协议。

CCNA学习之路

假设我们将R2ethernet0/0接口手动shutdown掉,那么R1会等待180秒(3分钟左右)之后,会将异常的路由标记被possibly down(可能down掉了的)状态 ,并不会直接删除,之后再等60(有的是240)秒,如果还没有收到该条目的更新,则会直接删除掉该条目。

CCNA学习之路

过了60秒之后,还没有收到该条目的更新,则会直接删除掉该条目。见下图

CCNA学习之路

在特权模式下使用show ip protocols命令查看当前路由运行的所有协议。

CCNA学习之路

发表评论 取消回复
表情 图片 链接 代码

分享